Nomeando grupo de células (range) no excel. Como usar?


Um recurso muito útil no excel e pouco usado pelas pessoas é o nomear células ou grupo de células (range).

Ele acabe sendo pouco utilizado pois as pessoas não veem o ganho de produtividade que este pode ter.

Vamos lá, primeiro vamos nomear um range (grupo de células).

Nomeando Células:

1) Selecione o range B3 ao C5 (B3:C5).

nomeadorange01

2) Marque com 2 cliques o “B3” na caixa de nomes ( onde o célula B3 está em azul) .

nomeadorange02

3) Digite um nome ( Eu sempre uso o underline “_” antes do nome. Mais pra frente explico o porquê).

nomeadorange03

Outra forma para nomear um range ou célula:

1) Selecione o range B3 ao C5 (B3:C5).

nomeadorange01

2) Clique no menu “Fórmulas”. na parte “Nomes Definidos”  cliquem em “Definir Nome”. Aparecerá o combo-box “Novo Nome” digite o nome. Neste caso usei “_teste”.

nomeadorange09

3) Verifique na “caixa de nomes” o nome que aparece é “_teste”.

nomeadorange10

Porque eu uso “_” (underline) para nomear ranges !

A idéia de nomear os ranges é poder usar com fórmulas e/ou funções.

Veja abaixo, se eu utilizasse somente o nome “teste” ele traria uma função junto com o nome.

nomeadorange04

Usando o nome com “_” (underline) veja que ele aparece com um ícone de etiqueta.

nomeadorange05

3 exemplos para o uso de célula nomeada.

1) Com a função Cont.se()

Nomeei o range C2:F7 de “_letras”

 nomeadorange11

Neste range tenho várias repetições de algumas letras quaisquer.

No range C20 ao C29 coloquei as letras sem repetição e usei a função CONT.SE() para contar a quantidade de vezes que ela se repete no range  “_letras”.

nomeadorange12

2) Com a Função SOMA()

Nomeei o range C3:F3 de “_vendaA”. Na coluna  G3 coloquei a função soma da seguinte forma:

=SOMA(_vendaA)

nomeadorange13

3) Com uso do PROCV()

Nomeei o range I2:J4 de “_custo_unitario” .

Na célula C3 usei o procv para saber qual seria o valor das vendas. A formula ficou assim:

=PROCV(A3; _custo_unitario;2;FALSO)  onde:

=PROCV(A3 = “a” ; consulta range para achar o “a”; retorna o valor da coluna 2, no caso “5”; trás correspondência exata “a” = “a”).

nomeadorange14

Dica:  Em versões anteriores do excel 2010 a opção de nomear fica em outro menu. “Inserir”.

nomeadorange15

Caso queira ter os exemplos como referência, clique no link para download:

Link para download:

Nomeando Celulas ou agrupamento de Celulas (range) no excel

One response to “Nomeando grupo de células (range) no excel. Como usar?

  1. Pingback: Dica funcionalidade tecla F9 para visualizar valores de cálculos no Excel | Excel B2B·

Deixe uma Resposta

Please log in using one of these methods to post your comment:

Logótipo da WordPress.com

Está a comentar usando a sua conta WordPress.com Terminar Sessão / Alterar )

Imagem do Twitter

Está a comentar usando a sua conta Twitter Terminar Sessão / Alterar )

Facebook photo

Está a comentar usando a sua conta Facebook Terminar Sessão / Alterar )

Google+ photo

Está a comentar usando a sua conta Google+ Terminar Sessão / Alterar )

Connecting to %s