Como usar função OU () e função SE () juntas.


 

Conceito:

A função OU () retornará “VERDADEIRO”  se um dos argumentos forem “VERDADEIROS”  e retornará “FALSO”  se todos os argumentos forem “FALSOS”.

Sintaxe e exemplo:

1. OU(Condição1; Condição2;Condição3)

2. OU(VERDADEIRO;FALSO;FALSO) será igual a VERDADEIRO.

3. OU(VERDADEIRO;VERDADEIRO;FALSO) será igual a VERDADEIRO.

4. OU(FALSO;FALSO;VERDADEIRO) será igual a VERDADEIRO.

5. OU(FALSO;FALSO;FALSO) será igual a FALSO.

Levando em conta que a função OU() retorna “VERDADEIRO” ou “FALSO”, juntamente com a função SE() usaremos  a função OU(), já que com a função SE() conseguimos ter uma ação, caso seja “Verdadeiro” e uma outra ação casos seja “Falsa”.

Leia mais sobre a função Se () em :

 FUNÇÃO SE (), COMO USAR ?

Leia mais sobre a função Se () e E() juntas em : 

CRIANDO AGRUPAMENTO COM FUNÇÃO SE(), E() E FUNÇÃO PROC()

Abaixo um detalhamento da sintaxe e de como a função OU() responde às condições:

SE() OU()

Situação:

Imagine que tenha uma planilha de dados onde, mediante um campo código, queira criar um campo de subcategoria.

Vídeo:

Aplicabilidade:

Vamos usar as funções separadas para melhor compreendê-las:

Em uma tabela que contenha um campo de codigo, neste caso será o campo “CAMP” este nosso.

pictureOU01

Crie uma coluna com o nome de “OU”:

pictureOU03

Digite a função OU(). Iremos usar 2 argumentos/condições para este exemplo.

pictureOU04

A condição será a seguinte:

A célula “B2” é igual à “CAMP001”; A célula “B2” é igual à “CAMP002”.

pictureOU05

A resposta para a função OU() será “VERDADEIRA” OU “FALSA”, conforme foto abaixo:

pictureOU06

Vamos criar uma outra coluna “SubCategoria” onde usaremos a função SE().

Se a célula “E2” for “VERDADEIRO” então mostre “EXECUTADOS” senão mostre “PENDENTES”.

pictureOU07

Abaixo como ficará depois da função SE() aplicada.

pictureOU08

Link para Download: funcaoOUeSE()

20 responses to “Como usar função OU () e função SE () juntas.

  1. Boa tarde, gostei do exemplo mas estou com dúvida de como usar SE combinado com múltiplos OU.
    Ex: Em uma planilha para calcular horas trabalhadas, tenho condições diferentes de trabalho de seg-qui, sex, sab e dom e feriados.

    A primeira parte funciona e ficaria assim:

    =SE(OU(A1=”seg”;A1=”ter”;A1=”qua”;A1=”qui”);IF(B2<C3;C3-B2);0)

    Até aqui funciona, mas eu preciso incluir outras opções como: (A1="sex");IF(B2<C2;C2-B2)

    E ainda outras para Sab e (Dom e Feriado)

    Alguma ideia que possa me ajudar?

    Obrigado!

    Guilherme

  2. por favor gostaria que me ajudassem com essa função
    entrada saida permanencia +1hr +2hrs +3hr +4hrs
    11:20:00 13:30:00 02:10:00 0 0 0 x 0
    onde quero que apareça x ou zero dependendo da permanencia , já tentei várias variações com a função se mas só da certo na primeira hora se eu coloco maior ou menor nas outras horas dá tudo errado, já estou a 2 dias com isso,,grato.

  3. Bom dia,

    estou precisando de criar uma função que me retorne 3 possibilidades de Resposta.
    SE(A1(>=14<29);"Férias Coletivas");SE((A1<14);"Sem Direito a Férias – Analisar";SE(A1<30);"Férias Regulamentares")

    Porém no primeiro dado como podem ver tem um intervalo de informações.

    Teriam como me dizer se teria alguma possibilidade de conseguir resolver?

    Att. e desde já obrigado.

  4. Passei dias tentando resolver um problema com boletim escolar, e nesta explicação consegui resolver, era no caso de recuperação substituir a nota ai usei a função SE(E…. Grato!

  5. Olá, Bom dia.
    Minha formula apresenta erro que não consigo identificar. Alguém pode me ajudar?
    =SE(H4>=3;”CANCELADO”;SE(H4>1;”Ligar Hoje”;”No Prazo”))
    Obrigada

Deixe uma Resposta

Please log in using one of these methods to post your comment:

Logótipo da WordPress.com

Está a comentar usando a sua conta WordPress.com Terminar Sessão / Alterar )

Imagem do Twitter

Está a comentar usando a sua conta Twitter Terminar Sessão / Alterar )

Facebook photo

Está a comentar usando a sua conta Facebook Terminar Sessão / Alterar )

Google+ photo

Está a comentar usando a sua conta Google+ Terminar Sessão / Alterar )

Connecting to %s